T5 HO from Amazon

FatalTrip

Member
Original Poster
Beardie name(s)
Julian
Please plug the fixture into another plug in in the house --- are you plugging it into a strip or just a regular plug in - ?
No, the hood did not work anywhere i brought it in store to test and it turns out the hood was broken, so great recommendations all in all, ill probably have to get two arcadias and use those if zoo med keeps being so unreliable.
 

FatalTrip

Member
Original Poster
Beardie name(s)
Julian
Why did it work in the store but not your house?
they only looked for breaks in the bulb and did not turn it on, but I brought that in and they showed me the bulb worked but the hood did not, i have the hood on a timer if that matters.
EDIT: I also bought another of the same hoods and am awaiting replacement from manufacturer and amazon.
 

KarrieRee

BD.org Sicko
Beardie name(s)
Hiccup he is 4 and Blaze is 3
they only looked for breaks in the bulb and did not turn it on, but I brought that in and they showed me the bulb worked but the hood did not, i have the hood on a timer if that matters.
EDIT: I also bought another of the same hoods and am awaiting replacement from manufacturer and amazon.
So do you have a working hood now then? And I dont know why it would not work on a timer - it seems they do it has been a while since I used a timer but it seems mine worked
 

xp29

Gray-bearded Member
Photo Comp Winner
Beardie name(s)
Zen , Ruby ,Snicker Doodles, Sweet Pea, Sinatra
The problem is the ballast in the hoods, they are not physically broken, the ballast just don't function correctly. Even though they produce uvb they are still in essence a fluorescent bulb and prone to the same failures as any fluorescent light and fixure. ..... I'm sure everyone has been at work or at church or wherever and there was that one friggen light that buzzed and flickered or maybe kept going out, .... ballast 😁
 

FatalTrip

Member
Original Poster
Beardie name(s)
Julian
The problem is the ballast in the hoods, they are not physically broken, the ballast just don't function correctly. Even though they produce uvb they are still in essence a fluorescent bulb and prone to the same failures as any fluorescent light and fixure. ..... I'm sure everyone has been at work or at church or wherever and there was that one friggen light that buzzed and flickered or maybe kept going out, .... ballast 😁
Gonna try to get someone to repair, but @KarrieRee I did get the hood at a store so now we have a working one and will have 3 all together, my girlfriends dad has needed one for their sulcata tortoise.
 

KarrieRee

BD.org Sicko
Beardie name(s)
Hiccup he is 4 and Blaze is 3
Gonna try to get someone to repair, but @KarrieRee I did get the hood at a store so now we have a working one and will have 3 all together, my girlfriends dad has needed one for their sulcata tortoise.
Where do you have the UVB? Top of screen or inside the tank? Your screen is going to determine placement and distance
 

Longfellow777

Sub-Adult Member
Beardie name(s)
Frey'ja
That’s what I’m saying. I agree with Karrie try different outlet. Maybe the circuit in your home. That’s not normal. May be an electrical issue.
 

Members online

Still Needs Help

Latest resources

Latest posts

Latest profile posts

lol i feel like i ask so many questions on this site but i just love it here!
so many questions & not enough days
I'm painting Devlyn's house while she brumates. You can message me to hold me accountable because I procrastinate >_<

Forum statistics

Threads
152,928
Messages
1,227,636
Members
74,822
Latest member
Eddiebeardie
Top Bottom