egg help! please O.O

Status
Not open for further replies.

pyrovamp

Hatchling Member
okay so my eggs are on day fifty i was trying to spray very lightly some water in to the vermiculite to bring my humidity up. its at 80% i think. i was just trying to add some need water to it and one of the eggs just like cracked on the under side!! embryo fluid :shock: :shock: went everywhere and it split on the under side of the egg. i have been getting it around 84-83 degrees F so i dont think they should have hatched anytime soon right!? Also the eggs on some are becoming slightly translucent in some spots but no dimples or signs of hatching! help any idea if i just killed a baby or if they are starting to hatch or wat? some droplets of water which was slight warm tap water but it was a very small droplet help please if anyone has and ideas i will post a pic here in a few!
 

joshuajw

Member
I just checked and the fact that the eggs are going clear probably means that the mother didn't have enough calcium that happened to me
 
Status
Not open for further replies.

Members online

Latest resources

Latest posts

Latest profile posts

Getting ready for another day. Feeling sleepy. 😴
I just walked into my room and instead of looking at me, Swordtail's eyes darted directly to the ice cream drumstick I'm holding
Finally replaced Swordtail's substrate
I miss you so much, Amaris 💔
What is a quick way to warm up a cold beardie? His heating element went out overnight and now he's very cold.

Forum statistics

Threads
156,046
Messages
1,257,129
Members
76,044
Latest member
SunshineP95
Top Bottom