New Mobile Device Support!

If you have any comments, questions, suggestions, or problems with the BeardedDragon.org Website, please post them here. Forum Community related topics and the like are also welcome here!

New Mobile Device Support!

Postby beardie » Thu Oct 16, 2014 7:36 pm

[TOPIC AUTO-LOCKED DUE TO INACTIVITY]

Hey everyone!

I've been working on a significant update to the code behind the scenes that handles the look and feel of the site. What I've done, and released today, is to add automatic support for different sized devices!!!

What does this mean to you?

Try using your smart phone to view the website (forums or other pages)... they are no longer TINY to fit on your screen. They've been adjusted to look good on smart phones and tablets and even adjust to changing the orientation of your device from vertical to horizontal.

I am hoping that this new layout will make things smoother overall both for those of you who regularly check the site from your phone, and those who have been wanting to but avoiding it because it just wasn't very friendly.

By the way.. if you're wondering where the navbar that was on the right went... check out the icons in the upper left and right corners (this is only applicable on smart phones and tablets; or browsers that are fairly narrow).

How can you help?

I tried to do all the testing I can. At a point, I had to just decide to push out the changes, and hope I got everything. However, I'm sure I didn't get everything. In fact, I know there are a few quirks specific to the smart phone size. I could really use your help to tell me if anything is not displaying correctly! While I love hearing how great it may be for you (I really do like hearing it), I also want to hear what isn't working great... so I can make it better!

I hope this new update will be a positive effect for everyone! Please let me know how it goes for you!

Cheers,
-Alex
Not a vet, just a concerned keeper
Image
User avatar
beardie
Site Administrator
Site Administrator
 
Posts: 10758
Joined: Tue Nov 27, 2001 1:47 pm
Location: Lake Forest, CA, USA

Re: New Mobile Device Support!

Postby CooperDragon » Thu Oct 16, 2014 7:59 pm

Thanks Alex! I'm on my iphone now. I had to scroll left a lot to read text. The reply text box is about halfway down the page. Less cutter amd scrolling would be helpful on a small screen.
Image
User avatar
CooperDragon
BD.org Sicko
 
Posts: 17641
Joined: Thu Mar 27, 2014 8:41 am
Location: Iowa City, IA

Re: New Mobile Device Support!

Postby beardie » Thu Oct 16, 2014 8:03 pm

If possible, can you take screen captures of what you're seeing? I don't think I saw that issue in any of my testing. Hopefully I can see what you're seeing.
Not a vet, just a concerned keeper
Image
User avatar
beardie
Site Administrator
Site Administrator
 
Posts: 10758
Joined: Tue Nov 27, 2001 1:47 pm
Location: Lake Forest, CA, USA

Re: New Mobile Device Support!

Postby beardie » Thu Oct 16, 2014 8:53 pm

I took care of the text box being far down. I decided to sacrifice smileys (only the showing/selection of them; still can type them if you know the character sequence) on phones. I figure, when on a phone, you're probably not typing a lot of extra stuff anyway. :)

As for the scrolling left... perhaps you somehow were zoomed in? I now limited zoom to 1.2x (was limited only by phone limits before). On horizontal view, it fixes it to 1x with no zoom support. I figured that some people still like to zoom in when reading, even if crazy big. If it continues to be an issue, I may just fix the vertical view on phones too. Tablets and horizontal phone views are fixed sizing already.
Not a vet, just a concerned keeper
Image
User avatar
beardie
Site Administrator
Site Administrator
 
Posts: 10758
Joined: Tue Nov 27, 2001 1:47 pm
Location: Lake Forest, CA, USA

Re: New Mobile Device Support!

Postby Taterbug » Fri Oct 17, 2014 5:17 am

The topics list looks great!
However I'm also getting layout trouble on my iPhone.
The articles are looking good, but show up first. Side to side scaling is too wide and I can't zoom out

Image
Image
User avatar
Taterbug
BD.org Addict
 
Posts: 5544
Joined: Mon Jul 01, 2013 9:13 am
Location: Central Ohio

Re: New Mobile Device Support!

Postby beardie » Fri Oct 17, 2014 7:04 am

Hmmmm... are you able to zoom out when that occurs?

Also, the first screen shot... is that the navigation bar (now under the upper left icon) just taking up the whole screen?? Is there anything else visible? Hmmm... I am thinking that some of the JavaScript isn't working as nicely as I'd hope. I saw that only once in my testing, and thought it was a fluke since I hadn't seen it again.

On my iPhone (running iOS 8, and one on iOS6, I think), I can browse. Occasionally, I have to zoom out for some reason. I may have to try an decreased font and automatically zoom in for vertical.

ALso, when you do see that, what happens if you rotate to horizontal? Do things suddenly look better?

For now, I think I may have to remove the ability to zoom. I suspect that may be what is happening.

Thanks for the feedback... more is welcome! Even if its people reporting the same issue.
Not a vet, just a concerned keeper
Image
User avatar
beardie
Site Administrator
Site Administrator
 
Posts: 10758
Joined: Tue Nov 27, 2001 1:47 pm
Location: Lake Forest, CA, USA

Re: New Mobile Device Support!

Postby beardie » Fri Oct 17, 2014 7:10 am

I just realized... if I make the change that I just made (remove zoom and fixing the scale), then you won't be able to tell me if zooming out was possible, since it's not possible now. heh.

But I guess... did you try zooming out then? Was it allowing you to?
Not a vet, just a concerned keeper
Image
User avatar
beardie
Site Administrator
Site Administrator
 
Posts: 10758
Joined: Tue Nov 27, 2001 1:47 pm
Location: Lake Forest, CA, USA

Re: New Mobile Device Support!

Postby Draycebaby2014 » Fri Oct 17, 2014 7:16 am

who hoo looks great thanks !! :)
Draycebaby2014
Juvie Poster
 
Posts: 300
Joined: Thu Apr 03, 2014 4:53 pm

Re: New Mobile Device Support!

Postby Taterbug » Fri Oct 17, 2014 8:16 am

I wasn't able to zoom - it would snap back. horizontal wouldn't let me pinch at all.

However. Now it's loading correct. Looks great! I'll post back of I come across anything :)

Thanks for the mobile support upgrade!!
User avatar
Taterbug
BD.org Addict
 
Posts: 5544
Joined: Mon Jul 01, 2013 9:13 am
Location: Central Ohio

Re: New Mobile Device Support!

Postby beardie » Fri Oct 17, 2014 10:01 am

Ok. I think that the change I made fixed the zooming issue at least. What I think may still be a problem is the consistency that the JavaScript is executing with. Even when I loaded this page, the script that resizes images in posts to fit the space didn't run. So those screenshots were bigger than they were supposed to be.

This could cause a number of issues, ranging from image resizing, to the navigation drop down menu and search drop down (upper corner icons), to ads not getting displayed properly (which would be bad from a site revenue perspective... Need to be able to pay the hosting bills and such). This is something I definitely need to look into, and maybe add some method of logging when all JavaScript that should run doesn't, for debugging.

Thanks again for the feedback. I'm going to try and force myself to use the site from my phone for a while to ensure I experience issues others might experience. I even test occasionally with my old work iphone.
Not a vet, just a concerned keeper
Image
User avatar
beardie
Site Administrator
Site Administrator
 
Posts: 10758
Joined: Tue Nov 27, 2001 1:47 pm
Location: Lake Forest, CA, USA

Re: New Mobile Device Support!

Postby CooperDragon » Fri Oct 17, 2014 10:18 am

Here are some screen shots of what I'm seeing:

This is what the screen looks like right after a thread loads (haven't scrolled, zoomed, or touched it)
Image

This is what the first post on the page looks like after just scrolling down
Image

Here is the reply box
Image
Image
User avatar
CooperDragon
BD.org Sicko
 
Posts: 17641
Joined: Thu Mar 27, 2014 8:41 am
Location: Iowa City, IA

Re: New Mobile Device Support!

Postby Taterbug » Fri Oct 17, 2014 11:45 am

Strange, that's how it was for me too... It's working fine now for me.
Alex, are your ads paid by impression or on-click?
User avatar
Taterbug
BD.org Addict
 
Posts: 5544
Joined: Mon Jul 01, 2013 9:13 am
Location: Central Ohio

Re: New Mobile Device Support!

Postby beardie » Fri Oct 17, 2014 12:18 pm

CooperDragon wrote:Here are some screen shots of what I'm seeing:

This is what the screen looks like right after a thread loads (haven't scrolled, zoomed, or touched it)

Thanks! That will help! I also JUST had it give me that issue where the navigation drop down took up the whole page, and was actually sized for full desktop size. I was on my desktop, but the browser was sized for iPad size. This is a good thing though, in that I now have the pages loaded WITH the issue, and I can start looking at the difference between the problem coming up, and when it didn't. I loaded another tab to the same forum index page, and refreshed it twice. The problem went away and things were sized right.

So, definitely some quirky issue. But I can now look at the debugging info, css, etc. for the one that worked right and the one that didn't. Hopefully I will figure this out. Not sure why it goes away with a refresh or two though. That's just weird, and unfortunately, the kind of issue that are generally harder to track down.

Also... can you guys include what browser you're using (especially if not the default of Safari on the iPhone). It's also possible that some of the HTML5 and CSS3 support may not exist on some other browsers (has existed on Safari for a long while).

Also, this issue with the scrolling and massive navigation bar... how consistent is this? Does it always happen? Most of the time? Sometimes? or Rarely? From what I can tell initially, it looks like the "media queries" for CSS3 are not loading (at least in my example of it). Which I do not understand, unless it's that that file is not being loaded right in the forums.

Also, if fairly consistent, can you check to see if its the same issue on the home page or care sheet? They actually use different ways of loading the page than the forums do. One possibility is that there's an issue with the caching of the templates that the forums do (possibility), causing the file that configures the media query based CSS. ... I know gibberish for many of you... but maybe some appreciate the detail. :)
Not a vet, just a concerned keeper
Image
User avatar
beardie
Site Administrator
Site Administrator
 
Posts: 10758
Joined: Tue Nov 27, 2001 1:47 pm
Location: Lake Forest, CA, USA

Re: New Mobile Device Support!

Postby beardie » Fri Oct 17, 2014 12:23 pm

Taterbug wrote:Strange, that's how it was for me too... It's working fine now for me.
Alex, are your ads paid by impression or on-click?

Ads served by Google are however the advertiser chose (usually on-click, but some are impression-based). I also have a number of direct banner advertisers who are based on the ad slot (roughly impression based, but not a hard fixed number... just estimated).

With this update, I actually had to modify how my direct banner ads worked (some bugs with the old way came to light when I redid the layout control). With my new way, and after stabilizing this latest update, I could build in more control over how the impression rates work. As it is, I now have a simple way to specify the percentage of time (by day, not display counts; but it averages out okay), instead of distinct "groups". It's cleaner to use now, but may require some more debugging to ensure ads are loading. I now also load Google ads THROUGH my code, instead of directly... so I may potentially risk affecting those ads if things aren't loading right. I have already noticed that there's a drop in "page views" for ads according to Google, but it may also be a slow Friday. I'd have to correlate it to overall page views for the site too. I can allow for a few days to establish if there's an issue or not. :)
Not a vet, just a concerned keeper
Image
User avatar
beardie
Site Administrator
Site Administrator
 
Posts: 10758
Joined: Tue Nov 27, 2001 1:47 pm
Location: Lake Forest, CA, USA

Re: New Mobile Device Support!

Postby CooperDragon » Fri Oct 17, 2014 1:54 pm

The main site and forum both look OK in Safari for me. I've been using Mercury for the forums because it refreshes the page on back so the threads I've seen disappear. I still see the issue from the screen shots under Mercury. The main site seems to be loading properly in Mercury, just the forums appear to be loading in a larger format.
Image
User avatar
CooperDragon
BD.org Sicko
 
Posts: 17641
Joined: Thu Mar 27, 2014 8:41 am
Location: Iowa City, IA

Next

Return to Website Comments

Who is online

Users browsing this forum: No registered users