Zoo Med Terrarium Controller SOLVED

Discuss substrates, lighting, heating, enclosure building ideas, share enclosure photos, and talk about any other enclosure-related topics.

Zoo Med Terrarium Controller SOLVED

Postby Blackenedsabbath » Mon Jun 10, 2019 8:53 am

Hello everyone,

I purchased one of Zoo Med's timers today, the one that's a power bar and timer combined, but my fixtures just won't plug into it?? My dome light fixtures are exo terra, so I wondered if maybe that was the problem. I tried plugging my UVBs fixture (since its the ReptiSun) into it, and that wouldn't fit into the outlet either. It's almost as if it's not deep enough for the plugs to fit.

I called the store I bought it from and they said they've never heard of that happening. Does anyone else have any information on this timer? A lot of online reviews say they have some complications; should I just return it or try another one?
Last edited by Blackenedsabbath on Mon Jun 10, 2019 6:01 pm, edited 1 time in total.
If this hooman is lost, please return to Pancake
Blackenedsabbath
Hatchling Poster
 
Posts: 179
Joined: Fri Jan 19, 2018 2:22 pm
Location: Canada
- Advertisement -
- Advertisement -

Re: Zoo Med Terrarium Controller

Postby CooperDragon » Mon Jun 10, 2019 10:13 am

Outlets should be a standard size. Do you have the plugs turned the correct way (one side is sometimes wider than the other)? Some of the strips also have protective covers over the outlets that require you to turn the outlet to completely expose the opening. The brand differences shouldn't matter at all.
Image
User avatar
CooperDragon
Moderator
Moderator
 
Posts: 24550
Joined: Thu Mar 27, 2014 8:41 am
Location: Iowa City, IA

Re: Zoo Med Terrarium Controller

Postby Blackenedsabbath » Mon Jun 10, 2019 12:24 pm

CooperDragon wrote:Outlets should be a standard size. Do you have the plugs turned the correct way (one side is sometimes wider than the other)? Some of the strips also have protective covers over the outlets that require you to turn the outlet to completely expose the opening. The brand differences shouldn't matter at all.


Yep, the plugs are turned the right way. It doesn't make any sense.

It doesn't look like there is any protective covering over the outlet, nor does it specify how to remove one if there is in the instructions. I can get the plug into it, but past the very end of the prongs it won't go in.
If this hooman is lost, please return to Pancake
Blackenedsabbath
Hatchling Poster
 
Posts: 179
Joined: Fri Jan 19, 2018 2:22 pm
Location: Canada

Re: Zoo Med Terrarium Controller

Postby CooperDragon » Mon Jun 10, 2019 12:54 pm

Very odd. Maybe it's worth a call to ZooMed Customer Service for advice on that particular model.
Image
User avatar
CooperDragon
Moderator
Moderator
 
Posts: 24550
Joined: Thu Mar 27, 2014 8:41 am
Location: Iowa City, IA

Re: Zoo Med Terrarium Controller

Postby Blackenedsabbath » Mon Jun 10, 2019 6:00 pm

CooperDragon wrote:Very odd. Maybe it's worth a call to ZooMed Customer Service for advice on that particular model.


I got my dad to look at it to see if an electrician could figure out what's going on, and the prongs inside the outlets are all angled together, which is why the plugs won't go into them. Guess I'm returning it after all.
If this hooman is lost, please return to Pancake
Blackenedsabbath
Hatchling Poster
 
Posts: 179
Joined: Fri Jan 19, 2018 2:22 pm
Location: Canada

Re: Zoo Med Terrarium Controller

Postby Jerrod » Tue Jun 11, 2019 10:23 am

Blackenedsabbath wrote:
CooperDragon wrote:Very odd. Maybe it's worth a call to ZooMed Customer Service for advice on that particular model.


I got my dad to look at it to see if an electrician could figure out what's going on, and the prongs inside the outlets are all angled together, which is why the plugs won't go into them. Guess I'm returning it after all.


I had the same problem with mine. The prongs would not want to open up. I just had to keep switching the plugs and working them in and they eventually plugged in. Or get something that will fit and pry them some. Just make sure its not plugged in. :wink:
Jerrod
Newbie Poster
 
Posts: 20
Joined: Fri May 31, 2019 11:29 am
- Advertisement -
- Advertisement -


Return to Enclosures

Who is online

Users browsing this forum: No registered users